Upload file issue

Hi I successfully managed to setup libretime on a Bullseye fresh instance using branch from PR here: https://github.com/LibreTime/libretime/pull/1292

I had to put a reverse proxy as I host several services. I managed to get that working also but I now have issues to upload file to libretime, it doesn’t work anymore and show the following error in /var/log/airtime/zendphp.log:

2021-09-04T22:15:31+02:00 INFO (6): libretime.XXXXX.XXX Moving file /tmp/phpiKzKx0 to /data/libretime/organize/VANUPIE - JOANIE (Acoustic version) (128 kbps).mp3
2021-09-04T22:15:37+02:00 ERR (3): libretime.XXXXXX.XXX [MediaController.php:190 - putAction()] - array_key_exists() expects parameter 2 to be array, null given

Does someone have this issue already or some insight on where to dig ?

Okay I just solved my issue. As I’m pointing to a domain name, let’s say libretime.example.com, airtime was requesting https://libretime.example.com/rest/media/12 which failed as this DNS record was pointing to my ISP public IP. I solved this by setting libretime.example.com as a localhost ip into the /etc/hosts of my os

1 Like