Seeking advice for moving a system from v3.0.1 using http to v3.1.0 using https

I’m respectfully asking for a little advice to get my Libretime installation online and working. My original system runs on a Kubuntu 20.04 machine – is Libretime 3.0.1 and was installed with “./install”. It runs only on my LAN.
In the past I’ve managed to make a duplicate of it to another machine running Ubuntu 20.04 by installing with the same argument as the original, then treating it like restoring a backup. Stop immediately after the install script runs – copy all the audio over - dump the database from the original and import it into the new system – change the public_url from the original to a new one ( – restart the and hey presto away it went. I’ve also taken this HDD and run it on another network for testing purposes by just changing the public_url in config.yml to a different IP address, and it’s worked fine.

Now I’m trying to put the system online and add the proper security and encryption to get it to run using a real domain name, which is working and tied to the IP of my new server.
The server is running Ubuntu 20.04.5 but trying to use the updated version (Libretime 3.1.0) and updated instructions for installing as “./install –listen-port 8080” I can’t seem to get it to work properly despite numerous tries, so I thought I should seek some advice on the method I should be using?
Do I need to use the libretime-api migrate command? In the past I haven’t needed to do that before.

Should I be using I use the newly created config.yml file - or a copy of the one where the database is coming from?

Thank you to everyone who puts their time and effort into Libretime. It’s an amazing piece of software. I am extremely grateful for any hints or tips that anyone can provide.

The last time I tried this I followed the instructions and ended up with something that didn’t work at all. Nothing on the screen and unable to log in. The logs were full of errors. I ran through all the uninstall procedures (not the audio) – deleted the /libretime directory, then reinstalled over the top of what I had.

Repeated all the install steps again, it complained a bit, and I ended up with something that “appeared” to be working. I could log in and see the sequencer running, and could see it was playing audio in icecast at :8000 and :8000/main, but couldn’t hear the audio.

When I tried to change the Libretime settings, or log in from any other device, I got the Oops message. I decided it was properly broken and that I should start again.

I’ve reinstalled the OS -. Libretime (3.1.0) is downloaded, unzipped and I’ve copied all the audio files back on to it

For the next step should I run the install as …

“./install --listen-port 8080

Or should I do it as

“,/install --listen-port 8080

so the database will import without errors?

Should I use the new config.yml?
or should I replace it with the one from the machine the database is coming from?

Then change the public_url entry in config.yml to the correct IP/ after the database is imported?

I noted in another discussion here that the public_url entry should not be followed by :8080 when it’s ready to go.