Upgrading Libretime with original install directory deleted

I have a question on upgrading Libretime from 3.0.0-alpha.3 to 3.0.0-alpha.4. I deleted the original install directory, which was a pull from Git. According to the Release notes Here I need to do a pull and run the “.install” script. What do I do if I no longer have the original install directory?


Thank you in advance!

I think that when you pull the latest alpha.4 it will recreate the install directory etc.

robbt, I am actually in the middle of upgrading Libretime, but after I ran through the setup but it already says there is a database setup? How do I get rid of the setup screen to see if everything is working?

I don’t know for sure. Do you still have /etc/airtime/airtime.conf ?
I think this is the file it uses to check to see if it needs to run the install screen or not.

No, the installer deleted the old config file, I am restoring the server back from image, I will backup that file and use it as a guide. I think this is why it says to use the original install directory and to update it and re-run the installer. It thinks it’s a fresh install.

Will keep you updated… Love learning the hard way, but thank God for Droplet snapshots!

Yeah to be honest I haven’t updated my server with some of the latest versions because I don’t trust our install file to do the right thing. For instance our install file should not overwrite or delete an existing config file but I don’t doubt that it did. At the very least it should backup the file. But this is one more thing for us to work on and there are quite a bit of things that could use attention.

Well, let me be your guinea pig!
So here is what appears to be happening so far… I run through the installer from a user account, not root, using sudo.
I answer to to all of the defaults, when it gets to PostgreSQL it says a user already exists, doesn’t tell me if it did anything, I am assuming it did not. I am also not sure if I should answer “Yes” to Apache, since it already is there, etc. So, I am now going to try to answer NO to the default questions and see what happens!
Restoring snapshot now.

OK… so going through the installer script again and answering “NO” to everything, still causes the conf file to get deleted. I copied the original airtime.conf file to /etc/airtime and all I get is a white screen. I restarted the following services:
invoke-rc.d airtime-media-monitor.service restart

sudo invoke-rc.d rabbitmq-server restart

sudo invoke-rc.d apache2 restart

sudo invoke-rc.d airtime-analyzer restart

sudo invoke-rc.d airtime-playout restart

sudo invoke-rc.d airtime-liquidsoap restart

Nothing changes, and I cannot get passed the initial login screen because it says the user name and/or password does not match.

At this point upgrading is just not working. Now, to boot, I have a problem uploading files that started after DigitalOcean upgraded their dropplets, they increased the disk size for free, but now I can’t upload files, says error, but the file is uploaded! Also, navigating to settings/status I get an “oops” page.

Any ideas on this one?