LibreTime install VPS which using DirectAdmin

Just install it the normal way and if anything isn’t working post here for help or with the workaround. If it just works then you can confirm that and/or write some documentation and open up pull request so that we can add either a note highlighting that LibreTime works on Raspberry Pi’s out of the box or else specific install instructions.

i found one issue.

Look a picture…4 step not going next step…loading and loading

Hmm weird, wonder what is happening, anything in the /var/log/apache2/error.log ? If you reload what happens, does it get stuck here every time ? Also check your JavaScript console on your browser.

I give you some pictures, maybe you find a problem :slight_smile:

I think the bug is that the code that parses the rabbitMQ settings and /etc/airtime/airtime.conf file is freaking out because of a ! character in your password. At least that is my guess based upon the logs and looking at what that file is. So sounds like we could open up an issue with how we are parsing that file. If you don’t have a ! in your password then I’m not sure you could look at /etc/airtime/airtime.conf to see on that section of it. But otherwise try setting a rabbitmq password w/o special characters and see if you run into the same problem.

yeah, i trying again and special charset take that

Do you know how to translate all libretime?

So it worked ?

LibreTime is translated through .po files for each language we support. Find the one for the language and you can translate it. You can also open a PR and share your translation on github.

Where can i find .po file?

airtime_mvc/locale/LANG_CODE/airtime.po
Basically find the code for the language you are seeking to translate further. If it is a new language then I’m not sure the exact steps but most likely you just add the LANG_CODE directory and create an airtime.po

I’m not 100% sure if there is an additional step you need to do afterwards.

Were you able to get the install working ? If so I’ll have to open up a bug for the installer to fix the issue with special characters.

How can i test my language code? my language is et_EE

So we would need to create this language as I don’t think it exists currently. It looks like you’d need to add it to the list in application/models/Locale.php and also create a directory under locales for et_EE and copy a airtime.po and translate it. It’d be great to get this added as a pull request at github. We have done some work to make an easier way to translate things but nobody had enough time to fully implement it as of yet, so things are still needing to be done manually like this.

Let me know whether this is something that you can do on your own or if you need me to do some work setting up the pull request so that you can share your translated version.

where is located application/models/Locale.php? if i use ./install -fiap, where does he install these files?

airtime_mvc/application/models/Locale.php
inside of the directory you downloaded LibreTime - to contribute a PR you need to use git. If this isn’t something you are comfortable with I can help with that part if you share your translated .po
At some point a .mo file needs to be generated from the .po file. I’m not sure at what step in the process this happens, perhaps when you are running the install or it may require an additional command. Basically the .mo file is a compiled binary from the human readable .po file

You can see this commit for an example of recent modifications for the Russian translation - https://github.com/LibreTime/libretime/pull/985/commits/5f3310da03a1642b3d45e80f218e50be4b672e70

Sorry this is so complicated but we haven’t built the proper infrastructure yet to make translations easy and I appreciate your interest in helping add an additional language.

Incase you’re not able to do it with git you can always get the po template file and use a program like Poedit to create a new translation and just share that file here.

Example:

Template:

So, I add .po and .mo file on my raspberry pi in location /home/pi/libretime/airtime_mvc/locale/et_EE/LC_MESSAGES/airtime.mo and airtime.po.

and I add next text to Locale.php file “et_EE” => “Estonian”. After that i take a reboot, but nothing change, i don’t see my language in language list

Ok, it looks like the install adds the language stuff via the database so try getting into the database and running -
INSERT INTO cc_locale (locale_code, locale_lang) VALUES ('et_EE', 'Estonian');

I think psql -U airtime -h localhost -W airtime from the command line with airtime as the password should get you in.

Okay, that’s fine :slight_smile:

But I have next problem :smiley:

If i click LISTEN button, i don’t hear radio

Screen Shot 2020-05-09 at 16.00.57

This can be a number of problems. One I just noticed a while ago is that the Listen pop-up uses autoplay and that is blocked by some browsers and there is no way to trigger it manually. At least saw this one Firefox.

Also the best way to verify things is to open up the stream from the Icecast server directly at port 8000 and see if you can hear your stream playing that way from a client like VLC or even your browser window (if it opens the mp3 automatically).

Otherwise check your icecast logs under /var/log/airtime/pypo/pypo-liquidsoap and see if there are any errors. Also good to check pypo.log

Let me know what if any of these solves the problem for you.

Yeah, problem is only Safari :smiley:

Some necessary things that LibreTime would desperately need.

  1. When I edit a song, there might be a place where I can set the cue in and cue out places exactly on top of the song, and so on for each song.

  2. Currently, fade in and fade out can be set on a per second basis, but are actually set on a dB basis. Maybe if a song falls below a certain dB then fade the next song in.

  3. In addition, a BPM could be shown for each song to know which criteria to set.

In short, it is as if such a song analyzer is missing.

Is there any way to set the end output or limit so that all songs are broadcast with the same sound level, and not one song is louder than another.