Got some bad time to figure our how to install on Raspberry pi 3 B

yeah I think the mp3 stretch issue has to do with the version of liquidsoap that is packaged, I’d try buster instead of stretch if possible.

1 Like

Sadly i get

Blockquote “Raspbian GNU/Linux 10 (buster)” is not supported with “raspbian-10”

This is probably easily fixable by changing the install script to accept raspbian-10 - feel free to open up an issue on github and hopefully someone can push a change to make it work.

1 Like

Thanks mate, just did and waiting to see what happens

Raspbian Buster is now supported in the installer

We still need to merge the liquidsoap 1.3 fix to truly support Debian Buster out of the box.

Thanks so much, i just did a fresh install and it seems to working! The only thing is that i still get an error with mp3s and my log writing

Failed to run: silan - No such file or directory. Do you have silan installed?

Should i use a specific version of silan? please assist

EDIT**

Finally i managed to use --fix broken install and now the server seems to accept and play the mp3 files.

At the moment i haven’t try to connect on my Shoutcast server yet, but when im clicking on the LISTEN NOW button on the server (through another computer on the network) i get no sound, why this may happens?

I’d recommend verifying that the Icecast server is runing at port 8000. If you didn’t apply the liquidsoap 1.3 fix airtime-liquidsoap probably crashed. If you did then things should be working. It’s possible that you are running into an issue with your browser and/or flash weirdness with the player if it works for icecast but not listen now.

Well, when im installing libretime and it is asking for setup the icecast i just hit “no” because i will make use of a shoutcast server to stream the music. Also i noticed that i can preview (play) the music files which are hosted on server without the liquidsoap update, does previewing the tracks uses another kind of player?

Yeah, that is independent of liquidsoap. You need the liquidsoap update in order to connect to shoutcast or play any of the files. It is what does the playback be it via icecast or shoutcast.

liquidsoap is already on 1.3.3 (also i tried to upgrade to alpha0.0.8 but is seems that the installation doesn’t support Buster)

At the moment im facing problems trying to use the SSL on the server. I’ve done it already on my Airtime (another computer running Ubuntu) but on Raspberry i followed these steps but i couldn’t find the file “/etc/apache2/sites-available/airtime-vhost.conf” so i made a new one, copied the code as the guide saying, finished the steps but nothing happened. Please assist

No there is a special patch you need to install until my PR gets processed to make Libretime work with liquidsoap 1.3, getting SSL to work out of the box is one of the next projects I plan to work on at some point.

See this post for the patch - https://github.com/LibreTime/libretime/issues/192 or this PR for the updated version - https://github.com/LibreTime/libretime/pull/931

The liquidsoap patch has been merged, so you shouldn’t need to apply any patches on the current development master for things to work. If you are following releases, you will still need to apply the liquidsoap 1.3.3 patch until alpha.9 is released

Just a quick here! It is possible to use an external ntfs hdd to be a the active file directory?
I run the installation again to get into the configuration screen (is there any way to go into that screen except running the installation again?) and typed the “/dev/sdb3/blabla/blabla” but the screen started to show the loading icon and it never get to the next step. I opened a second window to the http://localhost and it just took me to the libretime calendar. I logged in and on the status window it showed me again the default directory “/srv/airtime/stor/”

Simple answer, it might be possible but isn’t recommended.

Long answer, if you have a NTFS hard drive with existing files that you want to use in LibreTime you could test this PR - https://github.com/LibreTime/libretime/pull/908

If you are talking about using an empty external hard drive you should be able to set the FS via the web-based installer to the location - you would need to have it mounted and put in the mount point and not /dev/sdb3 - and using ext4 would probably be preferred to NTFS if there aren’t already pre-existing files.

I see! so what im trying to do atm is that im booting from an HDD with the same Buster installation, but this is what comes up

Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting setuptools
Using cached https://www.piwheels.org/simple/setuptools/setuptools-45.0.0-py2.py3-none-any.whl
setuptools requires Python ‘>=3.5’ but the running Python is 2.7.16

but since i have installed Python 3.7 (already made it default) why im keep getting that message?

LibreTime’s python apps are still written in python 2.7

But it seems that the installation is asking for a version higher than 3.5, but it is also doesn’t recognize my 3.7 default version, how should i proceed? It looks like a bug to me

Its some kind of weird python dependency issue. This stuff would take some time to figure out but is unlikely to be a bug in libretime.

Well it may be possible to bypass that bug with a fresh install of the OS then, probably because my latest try before that fresh OS was successful