Got some bad time to figure our how to install on Raspberry pi 3 B

Greetings guys and gals! First of i hope that everyone is having good time and i want to thank you in advance. Well for a month now im trying to figure out how to install the airtime on my Raspberry Pi 3 B. I’ve read a nice guide somewhere on the internet which had to install it on Rasbian 8 Jessie, tried it, made the install but had some problems and i couldn’t access the servers page (liquidsoap), so i made a fresh install of the OS and then i found that forum, which is really nice, but now im reading about version 9 Stretch and i have some really bad time trying to figure out which guide to use for installing the libretime. Which files should i pull form github? do i need to make any changes to the code before starting the installation?

Thanks in advance for reading my post.

I know of no official guide, if you found one can you send a link to it. I haven’t tries to install on a raspberry pi but I think cloning the latest repo and running install.sh would be the way I’d approach it.

well im not saying that this one is official, but is the only one i could find and seemed to work, at least for me, it works until a point

Pi3

Also i found that PDF which i didn’t had the chance to try it yet, but probably i will do tonight

Well i just tried the installation as the PDF suggested, but when it is time to edit the /etc/airtime/airtime.conf i found out that there is not any “airtime” folder on my “etc” tree :open_mouth:

Also after running the full install file, at the end (after installing every other package) i get this

E: Unable to locate package libzend-framework-php

Also on the installation code i found that

#Debian Squeeze only has zendframework package. Newer versions of Ubuntu have zend-framework package.
#Ubuntu Lucid has both zendframework and zend-framework. Difference appears to be that zendframework is for
#1.10 and zend-framework is 1.11

so what i need to do for Jessie? Should i try a fresh install with Squeeze?

Ok, so you really can’t depend upon those guides because they were written with airtime in mind. LibreTime has forked Airtime, and so it has a different install process. I would just try running ./install on a fresh installation of Debian Stretch, Jessie is no longer supported. You could also try Buster but would need to patch the liquidsoap stuff.

For instance we install Zend from composer now vs. the packages because we need to install a fork of Zend to maintain compatibility with the newest version of PHP.

I am considering trying to install on a Raspberry Pi 4 at some point. I don’t know how easy or what challenges you might come across but in theory it should be doable on a pi 3.

1 Like

Well, are there any steps to try it on RasbPi? i mean the Libretime

I found two packages, one is the LibreTime and one is the Debian LibreTime

UPDATE: tried the install with the Debian LibreTime package, everything looks normal but at the end of installation i get this

curl: (6) Could not resolve host: getcomposer.org

Also i don’t get the classic “airtime installed successful” message at the end
any useful tips?

You need to be connected to the internet with a working connection to the web.

The device was connected on the web through WiFi, that’s how i cloned the files from GitHub

From a shell on the Raspberry Pi, what is the output of the following?

ping getcomposer.org

i got pings like 80-121ms with some spikes but i get the bytes normaly

EDIT*

Finally after a reboot and running the installer again, the installation downloaded getcomposer, also i saw many new files and packages coming on!

everything seems that installed correctly. Im facing a problem with the setup of the database! Im hitting the localhost which leads me to the Database Settings window where i should use a username password name and host. At first there are some information written on, but these are not working :confused:

got the SQLSTATE[08006] FATAL

I’ve read on a post of yours that this may be similar error due to locale?

EDIT again it was my mistake trying to edit the default password, the first step was finished, then on second step i didn’t edited anything and when i click next i receive

Couldn’t connect to RabbitMQ server! Please check if the server is running and your credentials are correct.

EDIT rebooting and try again, passed the second step. everything looks running up and im really happy with the brand new looking, thanks for your time guys, i really appreciate your effort

I found a bug on calendar. Im trying to schedule a show on Sunday, which is starting on 00:00 am and stops on 03:00.

When i click the ending time, the show duration says 4 hours. The problems seems to be between 2 and 3 AM as there is a one hour missing on duration! If i schedule the show on repeat, the first Sunday shows normal but the next shows are scheduled between 00:00 to 04:00

Any comment?

Maybe it’s the time change in your country? next weekend in some European countries changes the hour in the range where you have problems. I had those same problems in old Airtime installations with the summer and winter time changes. I guess that bug from Airtime is maintained in Libretime.

1 Like

Yes, you where totally right on that one! thank you so much.

Finally i faced the .mp3 importation failure, i’ve read some topics on the forum but is there anything that works? like, do i need to upgrade Liquidsoap as that guide said?
Using the opam solution?

Here is my log
should i install silan? how? as i get more libraries missing :frowning:

2019-10-29 15:13:15,905 [message_listener] [INFO ] - Received ‘{“tmp_file_path”:"/srv/airtime/stor/organize/bonzai_progressive_bonzai_basik_beats_477_with_karim_s.mp3",“storage_backend”:“file”,“import_directory”:"/srv/airtime/stor//imported/1",“original_filename”:“bonzai_progressive_bonzai_basik_beats_477_with_karim_s.mp3”,“callback_url”:“http://127.0.1.1//rest/media/1",“api_key”:“1FC35I8KI6N9ANUKU0TU”,“file_prefix”:"”}’ on routing_key ‘’
2019-10-29 15:13:32,347 [cuepoint_analyzer] [WARNI] Failed to run: silan - No such file or directory. Do you have silan installed?
2019-10-29 15:16:16,721 [playability_analyzer] [WARNI] Command ‘[‘liquidsoap’, ‘-v’, ‘-c’, ‘output.dummy(audio_to_stereo(single(argv(1))))’, ‘–’, u’/srv/airtime/stor/organize/bonzai_progressive_bonzai_basik_beats_477_with_karim_s.mp3’]’ returned non-zero exit status -11
2019-10-29 15:16:16,725 [analyzer_pipeline] [ERROR]
Traceback (most recent call last):
File “/usr/local/lib/python2.7/dist-packages/airtime_analyzer-0.1-py2.7.egg/airtime_analyzer/analyzer_pipeline.py”, line 69, in run_analysis
metadata = PlayabilityAnalyzer.analyze(audio_file_path, metadata)
File “/usr/local/lib/python2.7/dist-packages/airtime_analyzer-0.1-py2.7.egg/airtime_analyzer/playability_analyzer.py”, line 30, in analyze
raise UnplayableFileError()
UnplayableFileError
2019-10-29 15:16:16,729 [message_listener] [ERROR] Analyzer pipeline exception:
2019-10-29 15:16:16,733 [message_listener] [ERROR] Connection to message queue failed.
2019-10-29 15:16:16,733 [message_listener] [ERROR]
2019-10-29 15:16:16,734 [message_listener] [INFO ] Retrying in 5 seconds…
2019-10-29 15:16:16,971 [status_reporter] [INFO ] HTTP request sent successfully.
2019-10-29 15:16:21,766 [message_listener] [INFO ] Listening for messages…
2019-10-29 15:16:21,771 [message_listener] [INFO ] - Received ‘{“tmp_file_path”:"/srv/airtime/stor/organize/bonzai_progressive_bonzai_basik_beats_477_with_karim_s.mp3",“storage_backend”:“file”,“import_directory”:"/srv/airtime/stor//imported/1",“original_filename”:“bonzai_progressive_bonzai_basik_beats_477_with_karim_s.mp3”,“callback_url”:“http://127.0.1.1//rest/media/1",“api_key”:“1FC35I8KI6N9ANUKU0TU”,“file_prefix”:"”}’ on routing_key ‘’
2019-10-29 15:16:22,871 [cuepoint_analyzer] [WARNI] Failed to run: silan - No such file or directory. Do you have silan installed?
2019-10-29 15:19:02,150 [playability_analyzer] [WARNI] Command ‘[‘liquidsoap’, ‘-v’, ‘-c’, ‘output.dummy(audio_to_stereo(single(argv(1))))’, ‘–’, u’/srv/airtime/stor/organize/bonzai_progressive_bonzai_basik_beats_477_with_karim_s.mp3’]’ returned non-zero exit status -11
2019-10-29 15:19:02,151 [analyzer_pipeline] [ERROR]
Traceback (most recent call last):
File “/usr/local/lib/python2.7/dist-packages/airtime_analyzer-0.1-py2.7.egg/airtime_analyzer/analyzer_pipeline.py”, line 69, in run_analysis
metadata = PlayabilityAnalyzer.analyze(audio_file_path, metadata)
File “/usr/local/lib/python2.7/dist-packages/airtime_analyzer-0.1-py2.7.egg/airtime_analyzer/playability_analyzer.py”, line 30, in analyze
raise UnplayableFileError()
UnplayableFileError

also when im trying install silan i got this

sudo apt-get install silan
Reading package lists… Done
Building dependency tree
Reading state information… Done
silan is already the newest version (0.3.3~nmu1).
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
silan : Depends: libavcodec56 (>= 6:11~beta1) but it is not installable or
libavcodec-extra-56 (>= 6:11.9) but it is not installable
Depends: libavformat56 (>= 6:11~beta1) but it is not installable
Depends: libavutil54 (>= 6:11~beta1) but it is not installable
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

After running the apt --fix command i can’t access the UI of libretime anymore, i tried to reinstall Silan 0.3.3 nmu1 but i still get the libavcoded error :confused: anybody has any idea?

What if you use Ubuntu 18.04 instead of Debian and see if that works. I had some trouble with Debian and Libretime before and just went with Ubuntu 18.04 which seems to work the best.

1 Like