Cannot get a running installation of Libretime with functional Webstreams

Libretime Developers!!

First of all, we really appreciate you guys! Thanks so much for Libretime! Our little non-profit used Airtime for many years and our radio station is an important offering to our community.

Airtime began to get really flakey for us around 2019 and thank goodness we found Libretime! We converted over to Libretime around 2020 and it has been more dependable than Airtime ever was.

Now we must move from the hosting provider we were using which has been running Libretime version fd1449674—and has been running flawlessly since December of 2020. I know how to restore a saved DB and get the settings right to migrate so I thought it would be no big deal.

To my dismay, I have not been able to get a fully functional version of Libretime installed on either my development system or on a Digital Ocean instance for the past two weeks. The main problem with Libretime alpha10 is that Webstreams do not work—instead they either don’t start at all or else they play for about 8 minutes and then quit.

Our radio station depends heavily on webstreams since we mix in one or more live programs (from Butt>>Icecast) as well as static content every day. I see a lot of github commits lately and so I’ve installed a lot of new builds lately in case this gets fixed any day. But I’m so desperate that I would be fine with installing an old version of Libretime—which works—but I’ve totally struck out.

What I have tried – all on clean, updated Bionic Ubuntu:

  1. Installed latest Libretime from git—Icecast fails to link up to Libretime regardless of settings in either—can’t stream with icecast with either default connection or with custom settings
  2. Installed git checkout of 3.0.0-alpha.10—install completes and functions, except Webstreams broken (explained above)
  3. (Older version might work OK?) – Tried to install older versions from git, 7,8x, 9x—install scripts error out and fail due to missing dependencies or wrong pathnames, etc….cannot complete install scripts
  4. (Older version might work OK?) - Install older version from older .debs----all fail to complete install script due to earlier mentioned missing dependencies, wrong pathnames, etc……except alpha6.2 install script does complete on Xenial—but most of the Libretime daemons fail (really fail and cannot be fixed by me)
  5. Installed from git with “git checkout 9f1e41e6fa8656d2aa2dc74d2ed07026bef38593”—under the premise that it fixes the icecast-libretime connection plus the webstream problem (found this as a discord post by a user)----install script completed and libretime runs—except webstreams broken (as above)
  6. From Libretime github issue on old-moldy liquidsoap 1.1.1 creating problems with webstreams due to one or more changes elsewhere (Problem: We want to upgrade to Liquidsoap >=1.3.x · Issue #192 · libretime/libretime · GitHub) I used an otherwise functional Libretime-alpha-10 install and attempted to fix the liquidsoap problems by upgrading from liquidsoap 1.1.1 to various newer versions by:
    a. Hairmare’s solution found near the beginning of the page----could not complete procedure (no surprise—it’s 5 years old….)
    b. Using Opam to upgrade to liquidsoap 1.3.7 (or other versions) after removing liquidsoap 1.1.1—Opam refused to pin install to 1.3.7 and would only install the latest liquidsoap 2.0.3—which Libretime daemon could not work with despite my best efforts.
    c. Install liquidsoap 1.3.7 (tried others as well) from source—many, many tries and .configure or make always failed due to package version or other inscrutable errors.

So….I’m in a situation where I already moved our Libretime installation to a new hosting environment and it’s running on Libretime alpha-10 because I missed catching the webstream fail issue in my testing. And I’m in hot water with listeners and others I report to—because I cannot make Libretime play webstreams—they just get 2 hours of silence.

Help me. Is there anything I’ve missed as far as getting Libretime to function fully—with webstreams?

My goal is to never pester developers with trite questions without giving it a really good effort myself to solve things. But I’m out of bullets and I’m about 2 weeks and 60+ hours in now trying to get a working version of Libretime going.

Thanks again. I just made a donation to Libretime out of gratitude for the use of Libretime we’ve had in the past.

I am just running a test now, i have managed to get 2 30min http streams to run fully, back to back. Tomorrow i will try a 2hr stream. and then install a fresh copy of Libretime on a digital ocean droplet, make the same changes, if it works i will tell you how to do it. Very simple fix that i stumbled on, whilst looking at Liquidsoap and icecast. Ive currently got it running on digital ocean with Ubuntu 18.04.
I will let you know the out come.

Darren

Thanks Darren—I’m very curious to see what you found.

I know from reading that jooola has fashioned a comprehensive solution to the Webstreams challenge that will be rolled into alpha-11 release. I’m trying to figure out what I’m going to do with my broken production server now—wait for alpha-11 release or pull an old snapshot out of EC2 and fire up a mothballed version just to get the Webstreams going again. It would be sweet to know roughly when alpha-11 will be out for that reason. But I know the developers are working their behinds off and will release it when it’s really ready.

As you can see I’ve tried a lot of things—so I’m super curious as to what you discovered.

Boyd

Hi, I am at a loss, this morning i got libretime to run a webstream for over 2hrs. I try again later and back to only 6mins. I adjusted Icecast, I found something online concerning Icecast and liquidsoap, it recommended turning the burst off and changing sources from 2 to 10. I did that and it worked. But as i said, a few hours later it doesn’t want to know, and now it won’t play https streams at all.
I’m going to use Libretime as a front end, and pay for something to use as a back end that enables scheduling webstreams. I have been looking at RadioJar, they do a Cheapish set up for £20 which is roughly 20eur. I have been using RadioBoss, but that isn’t good for backend.
I will have another go tomorrow, I will let you know.

Darren

For what it’s worth, I’ve used Airtime/Libretime 24/7 for almost 7 years and I think it’s a fantastic app. Nothing comes close as far as radio goes. During that time I’ve never had to deal with something like this webstream snafu for any substantial length of time—it just works. Our most recent Libretime server ran flawlessly for over 2 years and was rebooted perhaps a couple of times.

Our Libretime devs are doing their best coping with OS and component package version changes introducing mayhem and friction into their brew as well as adding new, cool features. From what I’ve gathered of reading about the error logs and core issues here, I somewhat doubt that those variables in icecast.xml that you mention would provide a perfect fix. I think the problem is in how liquidsoap is reacting to various situations–such as what comes before/after the webstream in the programming, if anything, and how the timing of that detection is treated by liquidsoap’s other rules. I might not be perfectly accurate in this description. But I know they will have this fixed soon.

I would love to know when Libretime 3.0.0-Alpha-11 will be pushed out. I know that the webstream problem will be solved in that release. Hang in there.

1 Like

I am definitely sticking with it. Unfortunately i am not very computer savvy when it comes to linux. I only have a small Internet radio station, that I enjoy doing. For now , I will run libretime with RadioJar, Libretime can do the music , prerecorded shows and live shows and RadioJar the Webstreams.
I agree that everyone has done an amazing job with developing Libretime, I am very impressed and really appreciate the hard work they have done. I wish i was as good as they are. Hopefully Alpha 11 will be ready to try soon.

Darren

1 Like

Hi Boyd, I have just downloaded the latest version,
chore: bump actions/checkout from 2 to 3 by dependabot[bot] · Pull Request #1668 · libretime/libretime · GitHub onto a Digital Ocean droplet with Ubuntu 20.04,
I did all the Ubuntu updates before downloading, then updated again after the download, then did the install. I created a show put a song before a webstream and after. So far the webstream is playing, 20 mins and counting. To start with the stream cut out after afew seconds when the first song was playing, I suspect an Icecast issue as the stream counter read 11mins and it took ages to buffer and start. But when the webstream started it streamed ok, but running with a 40s delay. I have noticed that it will only stream on default settings, I haven’t changed anything like passwords or anything yet, i am just seeing how the webstream goes. I hope this helps and if you can work the delay out please let me know.

Darren

Thanks Darren—yes they are definitely working on this.

I’m curious though, any time I have attempted to install Libretime on Ubuntu 20.04 it refuses and says it’s only good for 18.04. Did you have to do anything to get around that or have you ever seen that version check blow you out of the install script?
u2004
What am I missing?

1 Like

Yes I have had that, I ran all the ubuntu updates , downloaded Libretime then redid the updates. I read that some cloud suppliers run broken O/S, so its good too do updates. Is your Libretime working ok, I could get webstreams to run but not any music files. the files played but the stream only played for about 8seconds of each file and took ages for the Icecast player to Load. Im going to try a download on 18.04 to see if that solves it. Unfortunately, I haven’t got a clue on linux so can’t get error logs or stuff like that up, I am not sure what commands to put infront of the stuff in the troubleshooting page.

Darren

I do have a Digital Ocean droplet running Ubuntu 18.04 and Libretime 3.0.0.0-Alpha-10 and it runs correctly all except the webstreams. I installed it about 2 weeks ago.

But most of the work I do testing is on one of several KVM virtual machines which have snapshots that let me roll back or forward to positions which comprise a totally clean OS state. That means they are installed by me from ISO and updated to be “latest” periodically.

I did manage to install Libretime on Ubuntu 20.04 recently but it was not stable. As soon as I started streaming it would spawn an endless number of python-playout threads—each one consuming about 2% cpu resources. After about a minute the cpu is saturated and cannot continue.

Sounds like whats happening on the version I have on 20.04. I just tried installing on 18.04 from the new commit i sent you and It says problem with Liquidsoap. I think I will have to wait for Alpha11, as I said, I haven’t a clue when it comes to Linux, so don’t know where to start. Hats off to all of you that understands it, I can’t get my head around it. I have a working version, but without the webstream, so I will use that in conjuction with Radiojar so I can get the streams on that. I will get the best of both worlds and it means i have always got a fallback. I only have a small station that i am trying to build up, before Covid I was a truck driver, but I got Covid at Xmas 2020 and haven’t been able to work since. So the radio keeps me going.
If you know of any idiot guides , please let me know.

Cheers
Darren

Hi Boyd, I hope you are well, I was wondering if you had found a solution for the webstream problem. I see that Alpha11 is due for release next week, so fingers crossed. I know everyone is working hard to solve the issue, which I really appreciate, and I know everyone else feels the same.
I also have seen your post about SSL , so i might pic your brains next week.

cheers

Darren

I’m waiting for Alpha11 to come out. Looking forward to finishing migration of our server to a new host.

Did you try the ssl for Icecast method? It works if you just follow it and do all the steps.

If you had any difficulties I’m curious to hear about them.

I now have Libretime Alpha12 running on Ubuntu 20.04 and it is working much better for me than Alpha10 did. Webstreams seem to behave now—that was the major issue for me on Alpha10. And it seems as though Alpha12 works better (for me) in Ubuntu 20.04 than 18.04. I would rather use 20.04 at this point anyway—it has a newer Liquidsoap, Icecast, Postgresql, etc…somewhat more futureproof.

1 Like