Installation Issue


#1

From @CaptRR on Sat Aug 12 2017 04:24:09 GMT+0000 (UTC)

I have run into a weird install issue. When I run the install.sh, using sudo bash install.sh, I get the following error:
install: line 103: ./build.sh: Permission denied

I’m running ubuntu 14.04, but also got the same error on ubuntu 16.04. Not sure if anyone knows why this is happening, or maybe its an alpha related bug, or even a problem with the keyboard mouse actuator :slight_smile:

Thanks



Copied from original issue: https://github.com/LibreTime/libretime/issues/272


#2

From @Robbt on Sat Aug 12 2017 19:38:37 GMT+0000 (UTC)

Hmm, not sure. Are you installing it on a virtual machine or a physical device ?
You could try typing
chmod +x build.sh
This will give the command permission to execute. Not sure why it doesn’t have it in the first place.
Did you install via the zip file or a git clone ?


#3

We are not developers or coders. Former terrestrial broadcaster now launching an on-line radio station. The VPS server is in the USA. I am in the Caribbean.

We signed up for a VPS account. Installed Ubuntu 16.04 Server 64bit.
I have to use Terminal / SSH console on my local personal Linux Mint 18.3 16.04 64bit computer to access the VPS server to do the installation since I don’t have physical access to the server that will run LibreTime.
What is the easiest way to install LibreTime and keep it up to date as changes / bug fixes occur.

So far I see two approaches:

(1) The following link provides an installation script.
https://github.com/LibreTime/libretime/blob/master/install

(2) And the following link points to a tar.gz download for LibreTime 3.0.0 Alpha 4:
https://github.com/LibreTime/libretime/releases

Running the script (Option (1) may be the easiest of the two approaches for me. My question, though, is this: Do I copy the raw text of the script and paste it into a text file and name the text file LibreTime_Install.sh (for example), make this newly created file executable and then run the script from Linux Mint Terminal using SSH Console? If so, what command do I issue after pasting the raw script (see option (1) above) into the text file to make the text file executable?

However, option (2) may be just as easy. The concern that I have in general about the installation process is that the installation instructions located online includes references to Airtime easy setup which is admitted to be outdated.
The document also states:
"LibreTime should generally be installed on a dedicated host. By default, its installer will install and configure all its dependencies. At the moment, the installer works best on Ubuntu Trusty. ./install"
How does ./install relate to the install script in option (1) above? Or does it?

Please advise. I am not kicking tires. Even though LibreTime is in Alpha, we have decided to start using the program in production mode and grow with it as it improves.

I know that the post is long. But, I wanted to be as clear and as thorough as possible.
Tony

UPDATE:
Being the brave soul or dare-devil that I am, I went ahead and pasted the raw script code into text file I named LibreTime_Install.sh, made the script executable , transfered the script to the bin folder of the remote (VPS) server and ran it: Following is the output from that attempt to install LibreTime. Being a Linux (Linux Mint) newbie it is not clear to me what the problem is. But, it appears the script could not find something(s) it need needed to complete the install.

Tried to add the entire output from the installation attempt; but, the forum said that new users are only allowed two links per post. Here is the place where the script stops: Reading package lists… Done

  • package_list_file=/bin/installer/lib/requirements-ubuntu-xenial.apt
  • ‘[’ ‘!’ -f /bin/installer/lib/requirements-ubuntu-xenial.apt ‘]’
  • echo 'ERROR: package file does not exist: /bin/installer/lib/requirements-ubuntu-xenial.apt’
    ERROR: package file does not exist: /bin/installer/lib/requirements-ubuntu-xenial.apt
  • exit 1
    root@radio:/bin#

#4

It seems like you are going about it a bit wrong.
You need to download the whole repository (which will include the install script)
In a directory without a libretime directory in it run
git clone https://github.com/libretime/libretime.git
this will require git to be installed if it’s not already, sudo apt-get install git
then run the above command.
From here you should be able to run the install command, it is best to run it
sudo ./install -fiap
which will override the need to type anything into the options and just install it.

I hope this works, sorry for the late response, Discourse doesn’t do always inform me of new posts.


#5

Good morning robbt,

  Your instructions worked great. I was able to complete the

installation.

  I am having an intermittent problem uploading files. Sometimes

uploaded file stay in “Pending import” mode and then fails. I have
read through a number forum comments and found that at some point
in the past there was a compatibility issue with PHP7 with Debian
9 and Ubuntu Xenial 16.04.

  Secondly, for the life of me, I don't know why I can't hear sound

when I click on the “Listen” button.

  Related (maybe) to the second issue mentioned above. I can't get

the Shoutcast stream to work. (Note: I am using a “Custom / 3rd
Party Streaming”

  I am using a VPS at HiFormance. I pointed a sub-domain of a

domain that is hosted at tmdhosting to my HiFormance IP. But after
thinking about it I can just use my HiFormance IP hostname instead
because my LibreTime server is going to send a single stream to
Voscast’s relay / distribution server. (Note: I would have setup
a recording stream; but, my HiFormance server does not have a
sound card).

  So my question is: What steps do I take to reconfigure my

LibreTime server to use my VPS server IP address instead of
radio.thefreemansground.com? I am trying to avoid having to
re-install LibreTime and losing all of the broadcast content that
has already been updated.

  I am a Linux Newbie (Linux Mint 18.3 Cinnamon), (Recently went

Cold Turkey on Windows 7) But, I am not afraid of learning and
following instructions. So please advise send some instructions
and point me in the right direction for additional information.

Standing by for your response.

Regards,

Tony


#6

Ok, so there are a few things here.
One you want to change your domain name of your host ? This should be doable but I don’t think it is documented anywhere, it probably involves altering the apache config file and the hostname in /etc/airtime/airtime.conf but when you start messing around with config files it can be a big disaster if you mistype or don’t know what you are doing. I can’t provide instructions off the top of my head beyond that, to really figure out how to configure it would take a bit more time.

I really need to work on the media-import service so that we can make it much easier to import files. With regards to your issues with importing, there might be something in the logs, but I don’t think the airtime-celery.log is being created by default. Another issue I need to put some time into.

I saw an issue with Shoutcast is also happening, there is a recent issue on the LibreTime github where someone successfully worked through this, but I haven’t fully parsed the instructions to see what they did. I can look up the specific issues if you want to follow them, let me know if you aren’t able to find them.

Anyways, just wanted to get back with you. I need to prepare for my live radio show I’m doing in an hour and a half on wcrsfm.org


#7

Good evening Robert,

  Thanks for your reply. You may not see this email before later in

the AM.

  Sorted out the hostname / IP address issue. Also noticed that I

can import one or no more than two files at a time. So that will
suffice for now.

  Regarding the Shoutcast connection / configuration issue in

Streams: Yes, please look into that when you get a chance. I will
also see if I can get some more information. My VPS server does
not have a sound card. I uninstalled, purged and reinstalled and
the Icecast2 server. It may be a liquidsoap issue. So, please
if/when you get a chance, look into what may be the problem. I
will also search for information and let you know what I find

Regards,

Tony

#8

Hi Rob,

  Quick update. Shoutcast connection working. But, there is no

sound going to it; because. there is no sound. Changed hardware
output to “Portaudio”.

  Here is an update to my last email to you. (I've also posted this

to the Git Forum.)

  Hi. I am a new LibreTime user and Linux "convert". I have no

sound and the On-Air button does not come on. So, I issued the
following command.

systemctl stop airtime-playout

Here are the results:

  root@radio:/# systemctl stop airtime-playout root@radio:/# sudo -u

www-data airtime-playout 2018-03-03 15:45:08,515 [main ]
[INFO ] New locale set to: C Traceback (most recent call last):
File “/usr/bin/airtime-playout”, line 4, in import (‘pkg_resources’).run_script(‘airtime-playout==1.0’,
‘airtime-playout’) File
"/usr/local/lib/python2.7/dist-packages/pkg_resources/init .py",
line 750, in run_script
self.require(requires)[0].run_script(script_name, ns) File
"/usr/local/lib/python2.7/dist-packages/pkg_resources/init .py",
line 1527, in run_script exec(code, namespace, namespace) File
"/usr/local/lib/python2.7/dist-packages/airtime_playout-1.0-py2.7.egg/EGG-INFO/scripts/airtime-playout",
line 4, in runpy.run_module(“pypo”, run_name=“main “)
File “/usr/lib/python2.7/runpy.py”, line 192, in run_module fname,
loader, pkg_name) File “/usr/lib/python2.7/runpy.py”, line 72, in
_run_code exec code in run_globals File
”/usr/local/lib/python2.7/dist-packages/airtime_playout-1.0-py2.7.egg/pypo/main .py”,
line 154, in configure_locale() File
"/usr/local/lib/python2.7/dist-packages/airtime_playout-1.0-py2.7.egg/pypo/main .py",
line 144, in configure_locale current_locale_encoding =
locale.getlocale()[1].lower() AttributeError: ‘NoneType’ object
has no attribute ‘lower’ root@radio:/#

Then I issued the following command:

  **sudo -u www-data airtime-playout**

Here is the result:

  root@radio:/#  sudo -u www-data airtime-playout

  2018-03-03 16:14:20,566 [**main**      ] [INFO ]  New

locale set to: C

  Traceback (most recent call last):

   File "/usr/bin/airtime-playout", line 4, in

     **import**      ('pkg_resources').run_script('airtime-playout==1.0',

‘airtime-playout’)

   File "/usr/local/lib/python2.7/dist-packages/pkg_resources/**init**      .py",

line 750, in run_script

     self.require(requires)[0].run_script(script_name, ns)

   File "/usr/local/lib/python2.7/dist-packages/pkg_resources/**init**      .py",

line 1527, in run_script

     exec(code, namespace, namespace)

   File

“/usr/local/lib/python2.7/dist-packages/airtime_playout-1.0-py2.7.egg/EGG-INFO/scripts/airtime-playout”,
line 4, in <

  >

     runpy.run_module("pypo", run_name="**main**")

   File "/usr/lib/python2.7/runpy.py", line 192, in run_module

     fname, loader, pkg_name)

   File "/usr/lib/python2.7/runpy.py", line 72, in _run_code

     exec code in run_globals

   File

“/usr/local/lib/python2.7/dist-packages/airtime_playout-1.0-py2.7.egg/pypo/main .py”,
line 154, in

     configure_locale()

   File

“/usr/local/lib/python2.7/dist-packages/airtime_playout-1.0-py2.7.egg/pypo/main .py”,
line 144, in configure_locale

     current_locale_encoding = locale.getlocale()[1].lower()

  AttributeError: 'NoneType' object has no attribute 'lower'

  root@radio:/#

Finally, I issued the following:

  root@radio:/# sudo -u postgres psql -c "

SELECT *

        FROM cc_music_dirs;

    " airtime

And this is what I got.

id | directory | type | exists | watched


#9

You are having the locale missing issue check out - https://github.com/LibreTime/libretime/releases#issues-no-locale-3.0.0-alpha.4


#10

Hi robbt. I am very new to Linux, and Git. So I recently stumbled across again and noticed that you had answered my question. I put LibreTime aside and installed a ERP system on that VPS server instead. I now have another server with twice the memory and the bandwidth and would like to get the latest version or iteration of LibreTime running.

I used the following instructions to install LibreTime in the new server:

Install Libretime on Linux Ubuntu 16.04 64-bit server

sudo apt install git -y

git clone https://github.com/LibreTime/libretime.git

cd libretime
sudo ./install

sudo service airtime-playout start
sudo service airtime-liquidsoap start
sudo service airtime_analyzer start
sudo service airtime-celery start

The first time that I ran the installation I got the locale missing problem. So I fixed the locale issue and re-ran the installation and it worked.

The problem that I am having now is that I cannot upload mp3 or ogg files (I have only tried those file types). So I upgraded Silan to 0.3.3. And I am confused about whether or not I should upgrade LiquidSoap from 1.1.1 to >=1.3.0 and exactly how to do it.

Clicking the green check mark that is to the right of the gray listen box informs me that there is a new version available (3.0.0 Alpha 4. Will upgrading to 3.0.0 Alpha 4 fix the mp3 and ogg file upload problem. I want to start using this program in its latest version and update it as improvements are made. We are a small non-profit that need this program as the radio / audio news station that will be tied / linked to our soon to be setup / launched Superdesk based Caribbean / African / International news and education site. We know that the program is in its Alpha stage. But we are willing to use it .

Any help, suggestions, or instructions would be helpful.

Regards,

Tony