Docker Libretime MAC M1 Tips


I wanted to (and just managed to) get LibreTime working on my Mac M1 to test it out. Hopefully this post will help others to play around with LibreTime through docker on the M1.

Firstly, each time you run into an issue remember to start at the start of the steps. Every time I ran into an issue I needed to go through the 4 commands:
docker-compose run --rm api libretime-api migrate
docker-compose up -d
docker-compose ps
docker-compose logs -f

First issue I ran into was this error:
no matching manifest for linux/arm64/v8 in the manifest list entries

I fixed that by editing docker-compose.yml and forcing the platform on the LiberTime images:


    **platform: linux/amd64** <-- add this before all images that point to

The config.yml I used these settings just to get docker steps to work:

public_url: ""
api_key: "any_key"

Note:Check GitHub there seems to be an email version of the config.

New to docker this is all trial and error for me. I started seeing this error
failed to create shim task: OCI runtime create failed: runc create failed
What I need to do there was clean up docker. I loaded up the docker dashboard and deleted my instances, again starting over.

Now the docker server is running and I can start playing around. I hope this community is an active one as Libretime seem pretty awesome! Trying to decide if this will be a good fit for our station.