'Do not run Composer as root/super user' warning

Hi, sorry if that is too noob but I can’t get over the message Do not run Composer as root/super user upon sudo bash install -fiap

I’ve tried several workarounds, logged as a non-root user, changed permissions and ownership, reinstalled Composer, cleared the cache, tried export
COMPOSER_ALLOW_SUPERUSER=1; composer show; - It just doesnt’go!

Or is it to warn a user with the ‘root’ name to switch over to non-root and continue?

Could anyone please suggest a way of dealing with it?

I usually just ignore this message. Running composer as root is a security risk if you are using it on a established box and adding new software but for LibreTime it isn’t an issue as generally you only want to install LibreTime on a VPS or server that is dedicated to use.

Have you tried ignoring the message ?

:heart:

can confirm, this is the way to go. if you install from a tarball composer should not do anything and with .deb or .rpm packages this isn’t an issue either.