Immediate error when running install script

Just trying to check LibreTime out…following instructions on install page and when I run the install script I get the LIBRETIME ascii art followed immediately by

error:

Nothing else to indicate what the error might be.

Have tried with a domain name I own (ddns) and with my private network IP like this:

sudo ./install http://10.10.10.132:80

Same result each time. Using Ubuntu 22.04.

Any help appreciated…

In looking at the script I see why I am getting the error. It’s because Ubuntu 22.04 isn’t listed as a supported version. I think I’ll just add it to the script and see what happens.

Hmm…well it doesn’t work. Some files aren’t found and it never created the libretime user so I’m going to stop here and either look for another option or wait until there is support for jellyfish.

Hey,

The recommended distributions releases are listed here: Install | LibreTime
Ubuntu 22.04 is not supported yet: Ubuntu 22.04 LTS · Issue #1845 · libretime/libretime · GitHub

You can install LibreTime using docker-compose if you want: Install | LibreTime

If you feel like “Lets install on 22.04 anyway”, you can try to work around Ubuntu 22.04 LTS · Issue #1845 · libretime/libretime · GitHub by installing the dependencies by hand using the php sury apt repository and the liquidsoap version from the Github release page.

1 Like