Migrating from alpha8 to latest git

Hello, we’ve just moved an alpha8 LibreTime install in an Ubuntu 16.04 server to a v63db4e0b8 (nov30) install in a 18.04 server. (we found a Xmrig Trojan eating all the cpus in the 16.04 server a couple of days ago, but that’s another story)

We followed the backup guide in libretime.org/backing-up-the-server and it seemed to work allright except that we changed the hostname in the process and got to the RabbitMq issues point :slight_smile:

The “new” thing to me was that after following the steps in libretime.org/troubleshooting#rabbitmq-hostname-changes (which I’ve done quite a few times already) I was still getting a message related to Rabbitmq but with a different bit:


[message_listener] [ERROR] Connection to message queue failed.
[message_listener] [ERROR] (403, "ACCESS_REFUSED - access to exchange 'airtime-uploads' in vhost '/airtime' refused for user 'airtime
[message_listener] [INFO ] Retrying in 5 seconds...

The “airtime-uploads” part was new to me or at least I haven’t seen it before.

Checking the related part in the guide above:

rabbitmqctl set_permissions -p /airtime airtime

I realized the “airtime-uploads” part wasn’t present in the command but I wasn’t sure if it was implied in those permissions.

I listed the permissions set with:

#rabbitmqctl list_permissions -p /airtime
Listing permissions in vhost "/airtime"airtime	airtime-pypo|pypo-fetch|airtime-analyzer|media-monitor airtime-pypo|pypo-fetch|airtime-analyzer|media-monitor	airtime-pypo|pypo-fetch|airtime-analyzer|media-monitor

After trying a couple of times and searching a bit without success I just tried adding the required permission to the ones in the guide doing:

rabbitmqctl set_permissions -p /airtime airtime "airtime-pypo|pypo-fetch|airtime-analyzer|media-monitor|airtime-uploads" "airtime-pypo|pypo-fetch|airtime-analyzer|media-monitor|airtime-uploads" "airtime-pypo|pypo-fetch|airtime-analyzer|media-monitor|airtime-uploads"

Now I get :

# rabbitmqctl list_permissions -p /airtime
Listing permissions in vhost "/airtime"
airtime airtime-pypo|pypo-fetch|airtime-analyzer|media-monitor|airtime-uploads airtime-pypo|pypo-fetch|airtime-analyzer|media-monitor|airtime-uploads airtime-pypo|pypo-fetch|airtime-analyzer|media-monitor|airtime-uploads

and LibreTime seems to be working ok.

My questions are:

-Should the migration from alpha8 in ubuntu16 to v63db4e0b8 in ubuntu18 work ok?

I mean not only the database import and store folder copying but with the Libretime functioning itself.

-Are there any other things I should check in the new install?

-Are the docs outdated regarding RabbitMQ hostname changes?

as usual, thanx a lot,

I’ve just seen a Celery error in the “status” tab but dissapeared a couple of minutes ago.
I checked the Celery status :

Dec 01 17:01:34  celery[21968]:   File "/usr/local/lib/python3.6/dist-packages/amqp-2.6.1-py3.6.egg/amqp/channel.py", line 280, in _on_close
Dec 01 17:01:34  celery[21968]:     reply_code, reply_text, (class_id, method_id), ChannelError,
Dec 01 17:01:34  celery[21968]: amqp.exceptions.AccessRefused: Exchange.declare: (403) ACCESS_REFUSED - access to exchange 'reply.celery.pidbox' in vhos

and in rabbitmq/rabbit@servername.log

=I NFO REPORT==== 1-Dec-2020::17:34:50 ===
accepting AMQP connection <0.15677.8> ( ->

=INFO REPORT==== 1-Dec-2020::17:34:50 ===
connection <0.15677.8> ( -> user 'airtime' authenticated and granted access to vhost '/airtime'

=ERROR REPORT==== 1-Dec-2020::17:34:50 ===
Channel error on connection <0.15670.8> ( ->, vhost: '/airtime', user: 'airtime'), channel 1:
operation exchange.declare caused a channel exception access_refused: access to exchange 'reply.celery.pidbox' in vhost '/airtime' refused for user 'airtime'

The playback went on without problems. And when I checked the Status tab again everything was “green” again without touching anything.

I tried restarting Celery anyway but I’m still getting this error:
celery: amqp.exceptions.AccessRefused: Exchange.declare: (403) ACCESS_REFUSED - access to exchange 'reply.celery.pidbox' in vhos

Do the RabbitMQ credentials in your airtime.ini match with how RabbitMQ is configured?