Listener Stats from a 3rd Party Stream

Hello everyone,

I installed and activated LibreTime on a Ubtuntu 18 VPS and everything is running smooth so far. Now I want to read out the listener stats from the external Icecast server, but LibreTime always gives me back the “Please make sure admin user/password is correct on Settings->Streams page.” error.
Does anyone have any experience with this?

Thanks in advance

So you need to have the correct admin login under streams -> settings for every stream you want stats from. So just check the credentials you put in for the 3rd party stream for the external icecast server. In theory you should be able to login to https://hostname:8000 and click on administration and type in the same credentials. If that isn’t working then check your credentials with the admin of the icecast server. If they don’t provide you an admin login then libretime has no way of retrieving the Listener stats for its internal database.

I hope this helps.

Hello robbt, thanks for your fast reply. I also have access to the 3rd party icecast stream and i was entering the same admin credentials from the web interface. But still i get the error message…

Ok are you using the latest version from a git clone aka the git master branch or a specific release. I think I have duplicated this issue on my local box and I’ll have to investigate further to see for sure, it has been working in the past so I’m not sure what changed and so the version you are using would be helpful in determining that.

I am using Version 8498029cd from the master branch on Ubuntu 18.04. LTS with Kernel 4.15.
Thank you!

Ok it looks like you have spotted a bug that happened as we transitioned our python code to python 3 from python 2.7. I’ve opened up a bug report here - https://github.com/LibreTime/libretime/issues/1045

There should be a relatively simple fix but someone will need to resolve it, as we had this issue with some of the ways we were processing inputs with python 3.5 vs. the latest 3.7

Alright, thanks for the effort!