Libretime on alt https port /and/ behind NAT

I am trying to set up a test LibreTime instance for a nonprofit community radio station to experiment with.

They have precicely one public IPv4 address, currently used by their router, which provides their production VPN on 443.

On a clean install of Libretime, it works behind their firewall for users connected to the VPN - but few users will have VPN access (on purpose).

I changed the port in libretime-le-ssl to 4443 and redirected that port plus 8000-8004, pointed the host name publicly to the firewall, and to the libretime instance inside the LAN.

I get errors in RabbitMQ and LiquidSoap - the icecast server is running and responding but /airtime_128 is an invalid URL (404).

I did try installing clean on a virtual host with a public IPv4 on a public cloud and it worked - but the station will not be able to afford a VM on a commercial cloud provider with enough storage to run a station…

Has anyone got a guide to running LibreTime behind NAT?

I don’t think the station’s ISP will hand out a second IP address.

What I have done in an instance like this is setup the server up with an OpenVPN host that provides a full IP address. Then point DNS at that static IP and it works. I do have the openVPN set to restart periodically but it has worked. This isn’t a free option but it might be easier than figuring out the NAT situation.

I don’t understand what you are suggesting.

A VM on a public provider forwarding all ports to the Libretime instance behind the firewall?

Could you post the logs, and also maybe some screenshots? So we can better understand what the current configuration is like.

Beware that RabbitMQ errors can also happen when you change the hostname, look there in the section RabbitMQ hostname changes.

I already did the RabbitMQ repair.

Will post configs this evening.

Which logs do you want (all paths please, I am new to LibreTime, don’t assume I know which logs you want)

(I am in Pacific Time zone)

(redacted, see below)

oh wait…

trent@libretime:~$ ls /srv/
ls: reading directory '/srv/': Input/output error
trent@libretime:~$ sudo shutdown -r now
Connection to localhost closed by remote host.
Connection to localhost closed.
trent@desktop:~/chlyforumhelp/etc$ ssh -p 2222 localhost #tunnel
kex_exchange_identification: read: Connection reset by peer

Where did the external drive go? Could actually be a physical problem.