Intro screen doesn't show the calendar when i'm using another computer on my network

Greetings people! As you can see on the screenshot bellow, there are two pieces missing on my intro screen when i’m connecting on the LibreTime server using another computer on my network but i don’t have the same problem when i’m using the Raspberry Pi (server)

Any thoughts??

This has to do with the URL you have setup. If it is a local IP or a name that is only resolveable locally it won’t work without changing it to something that you can access from anywhere. Something like might help if you are using a dynamic IP, if your computer is only accessible internally behind your router you’ll need to setup port forwarding and there might be a desire for a reverse proxy setup but that is usually used with docker based setups and requires some additional tweaking.

1 Like

I tried using the duckdns service but still works the same this time i tried to get connected through my cellular data (not being on the same router).

You’ll need to change the URL that LibreTime uses to the duckdns one I suspect
the base_url = URL
under /etc/airtime/airtime.conf
and I think that will fix it.
It might also break it (as there might be another place the URL is stored) so be sure to backup your existing URL and /etc/airtime/airtime.conf before editing it.