How to fade out shows

Hi, I’d like to know how you usually manage the ending of shows which content is dynamically generated using blocks or lists and is longer than the end time.

Usually we get into the situation where songs are being abruptly cut at the end of a show since:

  • it was programmed using a smartblock set to “Allow last track to exceed time limit”.

  • it was programmed using a list that is dynamically generated by different blocks (songs, sweepers, songs, promos…)

  • it was manually programmed with a longer song than the remaining time.

This is the way we wanted it to happen, we have no problem with the song being cut, but we’d like to be able to do it in a softer way .

AFAIK the “fade in/out and crossfade” settings are related to adjacent tracks but not to the beginning or ending of shows (or lists/blocks).

Am I missing something?

Are there any tricks to achieve this?

thanks for any hints!

In the “Settings, General” screen there’s a field for “Default Fade Out (s)” which we’ve set to .3s It seems to fade out even between shows, and more gently than 0s. Since we also have spoken word programming that exceeds some timeslots, we don’t want to fade out too slowly, either. That just sounds bad…

–Bob.

So the “Default Fade Out (s)” option works for every track’s end, even if it’s ending because the show in which is placed is the one ending (and not the track itself)?
thanks!

Hello!

image

I have this settings and my shows ends without fade out. How to fix it?
Shows programmed with autoloading playlists with dynamic SmartBlocks. "Allow last track to exceed time limit” enabled.

I don’t hear any difference when change “Default Fade Out” time

logs

2022/08/10 06:00:00 [server:3] New client: 127.0.0.1.
2022/08/10 06:00:00 [lang:3] vars.show_name
2022/08/10 06:00:00 [server:3] Client 127.0.0.1 disconnected.
2022/08/10 06:00:01 [cue_cut_9659:3] Cueing out...
2022/08/10 06:00:01 [cross_9665:3] Analysis: -17.615671dB / -nandB (0.00s / 0.00s)
2022/08/10 06:00:01 [crossfade:3] No transition: using default.
2022/08/10 06:00:01 [schedule_noise_switch:3] Switch to map_metadata_9743 with forgetful transition.
2022/08/10 06:00:01 [lang:3] transition called...
2022/08/10 06:00:01 [decoder:3] Method "FFMPEG" accepted "/var/lib/libretime/playout/scheduler/30.mp3".
2022/08/10 06:00:01 [dummy(dot)2:3] Source failed (no more tracks) stopping output...
2022/08/10 06:00:01 [dummy(dot)4:3] Source failed (no more tracks) stopping output...
2022/08/10 06:00:01 [s4:3] Prepared "/var/lib/libretime/playout/scheduler/30.mp3" (RID 0).
2022/08/10 06:00:01 [schedule_noise_switch:3] Switch to map_metadata_9732 with transition.
2022/08/10 06:00:01 [lang:3] transition called...
2022/08/10 06:00:01 [switch_9730:3] Switch to insert_metadata_9715.
2022/08/10 06:00:01 [lang:3] timeout --signal=KILL 45 libretime-playout-notify media '96018' &
2022/08/10 06:00:01 [lang:3] Using stream_format 0
2022/08/10 06:00:01 [lang:3] Using stream_format 0
2022/08/10 06:00:01 [lang:3] Using stream_format 0
2022-08-10 06:00:02.056 | INFO     | libretime_playout.notify.main:media:47 - Sending currently playing media id '96018'

Do you have working fade-out/fade-in between shows?
https://chat.libretime.org/libretime/pl/6gpuwf8mrtggjk8xdbg68ogeue