Getting AAC to work?


#1

So my test installation of LT is now working smoothly having sorted . …

BUTT connection issues
Done the Silan fix
Installed certbot so that DJ logins can be done under https

I want to use LT now to displace AT. Only niggling issue, and its stopping me switching over, is that streaming in AAC fails to work. Is this something to do with Liquidsoap ?

If there are any pointers as to how get AAC up and running on LT I would be keen to hear them.

Thx

Paul


#2

Definitely related to Liquidsoap, not sure that the default liquidsoap provided by repositories provides AAC. I’m not sure if anyone has been able to get it working.


#3

Thx robbt.

So an AT install does provide AAC that works. Is it workable (sensible?) to use the AT version of liquidsoap to access AAC and if so how would one go about that ?


#4

If I remember from 2.5.2.1, I had trouble there too but solved it on that system. Looking at my old setup files, I had to create specific mount-points for all my streams and it then woke up. See the comments in /etc/icecast/icecast.xml Worth a go? This was for the internal AAC LS codec. AAC worked very well @96kbs stereo but AAC+ was like a Dalek in a trash can. NB. External LS plug-in support was not compiled into AT’s LS 1.1.1 Holler @ me on Skype, Paul.