Getting AAC to work?


#1

So my test installation of LT is now working smoothly having sorted . …

BUTT connection issues
Done the Silan fix
Installed certbot so that DJ logins can be done under https

I want to use LT now to displace AT. Only niggling issue, and its stopping me switching over, is that streaming in AAC fails to work. Is this something to do with Liquidsoap ?

If there are any pointers as to how get AAC up and running on LT I would be keen to hear them.

Thx

Paul


#2

Definitely related to Liquidsoap, not sure that the default liquidsoap provided by repositories provides AAC. I’m not sure if anyone has been able to get it working.


#3

Thx robbt.

So an AT install does provide AAC that works. Is it workable (sensible?) to use the AT version of liquidsoap to access AAC and if so how would one go about that ?


#4

If I remember from 2.5.2.1, I had trouble there too but solved it on that system. Looking at my old setup files, I had to create specific mount-points for all my streams and it then woke up. See the comments in /etc/icecast/icecast.xml Worth a go? This was for the internal AAC LS codec. AAC worked very well @96kbs stereo but AAC+ was like a Dalek in a trash can. NB. External LS plug-in support was not compiled into AT’s LS 1.1.1 Holler @ me on Skype, Paul.


#5

has anyone else attempted to get AAC+ to work with liquidsoap/Libre Time? I’m trying it myself right now and I am wondering if there is any new information. Thanks.


#6

Not to the best of my knowledge. Feel free to share any issues that you run into here or on the github.


#7

It is possible to use AAC+ in liquidsoap by installing libfdkaac-ocaml-dynlink from contrib in Debian or multiverse in Ubuntu. I haven’t tested this with LibreTime, but it should just work after a restart


#8

If anyone comes up with a solution and/or is able to test the contrib package @paddatrapper suggests for this there is an open issue on Github that you can update.


#9

You can switch liquidsoap to an OPAM install of liquidsoap 1.3.* as described in the liquidsoap docs or install the testing (aka Buster) packages @paddatrapper pushed (along with the libfdkaac-ocaml-dynlink and fdk-aac packages from testing non-free).

You might also need to patch your LibreTime installation according to the instructions in LibreTime/libretime#192.

That should get you both AAC and HE-AAC (AAC+) since lots of fixing was recently done. Currently %fdkaac which supports both AAC standards only works for Icecast, SHOUTcast support should be working in 3.0.0-alpha.7. The old %aac and %aacplus encoders in liquidsoap are obsolete nowadays (in current liquidsoap 1.3.*).

Given the “official” statement on gnu.org it doesn’t look like fdk-aac will have a rosy feature due to its GNU incompatibility. It’s to note that it depends on how you compile fdk-aac, you can disable features (like, I think, parametric stereo) that have active patents on them.

This leads to the situation where it really depends on what kind of HE-AAC you would like to use (ie. what profile/version, the bitrate, possible regulatory/provider concerns).
Sadly, in most broadcast situations you are likely better off with a commercial encoder that gets the best quality out of your HE-AAC streams due to it including a version of the fraunhofer sdk better optimized for broadcast. AFAICT the fdk code is only open source due to google paying for it to be open for talk interop reasons, this version of the codec isn’t very geared towards broadcast usage.