Best way to begin development?

Hi to all, new to libretime development, i would like to help on development, where should i start? The best option is vagrant or a local install?

Now facing a problem on retrieving icy-metadata when the stream is ogg vorbis, it doesn’t send artist, album and title strings but instead it only yields the “StreamTitle”; I guess i should look inside liquidsoap configuration?

Thanks to all

1 Like

The vagrant set up is very handy for local development. It will provision a fully working local instance for you to develop against that you can recreate easily. For docs on how to set it up, see LibreTime - Using Vagrant for local development

Have you set the settings correctly on the Stream Settings page? LibreTime - Settings (Stream Label and Icecast Vorbis Metadata)

Thanks a lot, i’m going to use vagrant so. Are there boards or tasks pending to be done? Where i can see them?

I guess i should update my libretime installation, because i don’t see the Icecast Vorbis Metadata option. I installed the project starting from commit: 757e4929a6ed208785ad364bf611e3fcace2ac3e, should I do some operation before updating? ( is dead).

Depending on where your interest lies, these may be interesting:

It should definitely be there with the version you are running. It came over from AirTime when we forked.
Screenshot_2021-02-02 UCT Radio

Thanks! Ok, so github is the reference for bugs and tasks, looking into it!

Found out i have Icecast Vorbis Metadata already checked and the result is that the vorbis metadata that is being sent is just the StreamTitle, that is the Stream Label we set from the interface. Is this some liquidsoap configuration?

Yeah, possibly. It could be how the metadata is being sent to liquidsoap

I’m trying to use Vagrant, but get errors when running vagrant up for the ubuntu version:

    ubuntu-xenial: Traceback (most recent call last):
    ubuntu-xenial:   File "/vagrant/python_apps/api_clients/", line 23, in <module>
    ubuntu-xenial:     data_files=[])
    ubuntu-xenial:   File "/usr/local/lib/python3.5/dist-packages/setuptools/", line 153, in setup
    ubuntu-xenial:     return distutils.core.setup(**attrs)
    ubuntu-xenial:   File "/usr/lib/python3.5/distutils/", line 148, in setup
    ubuntu-xenial:     dist.run_commands()
    ubuntu-xenial:   File "/usr/lib/python3.5/distutils/", line 955, in run_commands
    ubuntu-xenial:     self.run_command(cmd)
    ubuntu-xenial:   File "/usr/lib/python3.5/distutils/", line 974, in run_command
    ubuntu-xenial:   File "/usr/local/lib/python3.5/dist-packages/setuptools/command/", line 67, in run
    ubuntu-xenial:     self.do_egg_install()
    ubuntu-xenial:   File "/usr/local/lib/python3.5/dist-packages/setuptools/command/", line 98, in do_egg_install
    ubuntu-xenial:     easy_install = self.distribution.get_command_class('easy_install')
    ubuntu-xenial:   File "/usr/local/lib/python3.5/dist-packages/setuptools/", line 755, in get_command_class
    ubuntu-xenial:     self.cmdclass[command] = cmdclass = ep.load()
    ubuntu-xenial:   File "/usr/local/lib/python3.5/dist-packages/pkg_resources/", line 2450, in load
    ubuntu-xenial:     return self.resolve()
    ubuntu-xenial:   File "/usr/local/lib/python3.5/dist-packages/pkg_resources/", line 2456, in resolve
    ubuntu-xenial:     module = __import__(self.module_name, fromlist=['__name__'], level=0)
    ubuntu-xenial:   File "/usr/local/lib/python3.5/dist-packages/setuptools/command/", line 719
    ubuntu-xenial:     ):
    ubuntu-xenial:     ^
    ubuntu-xenial: SyntaxError: invalid syntax
    The SSH command responded with a non-zero exit status. Vagrant
    assumes that this means the command failed. The output for this command
    should be in the log above. Please read the output to determine what
    went wrong.

When I try vagrant provision I get the following error:

    ubuntu-xenial: ERROR: unknown location of Apache sites-available or virtual host directory!
    The SSH command responded with a non-zero exit status. Vagrant
    assumes that this means the command failed. The output for this command
    should be in the log above. Please read the output to determine what
    went wrong.

Anyone familiar with this issue? Not sure what to do to fix it.

Looks like an issue with the underlying vagrant setup. Do other machines (like with following the vagrant quickstart docs) work in it and is volume mounting working. What host distro are you on? Can you post the exact vagrant up command you are executing?

Also, I updated your trust level so you can create your own thread on this.

@hairmare Thanks for the reply and the trust. I used vagrant up ubuntu-xenial and vagrant up and get the same error with both. I guess I will create my own thread. I’m on vagrant 2.2.5, so I will try upgrading.

After upgrading Vagrant to the most recent version, I get the following error with vagrant up:

debian-stretch: error: Setup script exited with 'pkg-config' not found.
debian-stretch: Command ['pkg-config', '--print-errors', '--exists', 'cairo >= 1.13.1']

Debian Stretch is EOL, try Debian Buster or Ubuntu Xenial

Thank you! Debian Buster worked for me. (Xenial gave me the same errors I was getting before.)