Switch to Wintertime

In the weekend of October 30 and 31 we switch to wintertime. This means that actually there will be an extra hour between 02 and 03 hours. How is libretime going to react? playing the show twice or is there a possibility to add an extra hour in the calendar?

Kind regards,


From our experience the clock jumps back so 1am becomes 2pm so there is not really a gap just calender shows there is

I looked it up and actualy 3am becomes 2am so the show programmed between 2am and 3 am will play twice.

This is an interesting case that LibreTime doesn’t actually account for. The database setup works on the assumption that a date and time is unique over the life time of the install. The system time is used to determine what should be playing at the moment, so I suspect that the schedule over that hour will play twice (haven’t tested it though). You can change it while it is happening (I.e. Edit the schedule in the fly if someone is awake), but there isn’t a way of creating an additional schedule for the second hour. Going the other way (moving forward an hour) will result in an hour of the schedule being skipped instead

The hour skipped actualy happened back in march. But i think this is something that should be adressed for next year :stuck_out_tongue:

And still something is happening
This show start at 00 and stops at 02 and the duration is … 3 hours.
Does anyone knows what is going to happen here? do we need to provide extra songs in the show?

OK here is what happened: The length of the show between 01 and 02 is two hours. Libretime works fine. It just was not clear beforehand what would happen. So i guess we can close this item.
Thank you all for your insights.

We had an hour of dead air between 2am EDT and 2am EST. The tracks between 1am EDT and 2am EDT played properly, and were marked in the track list as played (dimmed). Then the clock set back to 1am EST, but LibreTime did not play those tracks again, indicating there was no scheduled content. I was not able to cancel the scheduled program (it had already played), and was not able to insert new track in the current stream. Once the time reached 2am EST the playout resumed of the scheduled tracks.

I’m running a version from March 2020, labelled “6ac31f3a1” in the “Settings, Status” screen. I’m just recording this behaviour here, I’ll install a more up-to-date version and test to verify this before filing an actual bug report.

In addition, the calendar shows a strange overlap of shows at that time (screenshot below). The show at 1am should be only one hour long, but shows as two hours on the calendar. I’m not sure if this is a symptom of the DST problem, or if it’s a different problem. I’ve seen this kind of overlap before when doing some complex scheduling such deleting single instances, and scheduling shows in alternate weeks.


Switched my LibreTime interface to UTC instead of “Station Time” (which is now Eastern Standard Time UTC-0500, was Eastern Daylight Saving Time UTC-0400). And now the schedule shows a one-hour gap at the time where the clock was moved back from 2am EDT to 1am EST.

Just an interesting observation. Will test on a more recent version IMCAOSP.