Stopping duplicut songs and artists from playing too often

How do I stop the same song or artist from playing each hour?

Perhaps you have the “Link” box checked for repeating shows. That makes the same tracks play for every instance of the show.

I find it better to uncheck “Link”, then use an Autoplay Playlist which contains a Smartblock that chooses tracks randomly.


Thank you, Bob I’ll try that and let you know how I get on!

there’s a similar topic here: