Smartblock with new Track Type fails

Hi, we’ve run into a couple of failures with some new smartblocks using new track types.
We’ve created a new track type and assigned 2 tracks to it.

Type Name: Sweeper Clasicos
Code: SWP Clasic

When we tried to create a smart block using it, it wouldn’t find any matching tracks.

Then we created another new track type to test. This time we didnt use any complex code (no whitespaces in the code):

Type Name: sweeper clasico2
Code: swpclasico2

This time it worked fine.

Also, a couple of days ago we created another track type and assigned it to some new just uploaded tracks.

Type Name: Music FDS
Code: Music Fds

Then we created a new smarblock with the track type criteria and the preview matched the tracks correctly. But when we added a “last played” criteria to before 5 hours (just like we are already doing with many other blocks) it wouldn’t match any tracks. Just to try I inverted the time parameter to after but also didn’t match any tracks.
Could this be related to the track type code?
Any ideas or hints to try?

Libretime version: ecd302068 on Ubuntu 18.04

That’s seems to be the case, don’t use any spaces for the type code. I forgot to add something to prevent one from adding spaces on that field or lowercase letters. It’s intended to be use for quick and short unique codes like many fm radio systems where one can quickly identify the type on the library. You can always give it a full name for that type and it will be what you see on the drop down menus or if you hover your mouse (on type code) in the library.

1 Like

Hi, in Track Type we use a 3 letter code like SPX for Specials.
We have about 90 Track Type and it’s nice to use.
I have observed following : I made some tests using Track Type filter in Smart Blocs and Playlist for to look what happens. There is effectively a problem when we apply Smart Blocks.
It looks like a small error in the code.
In order to always select the newest show in the programme repeats, we use the following filter. Track Type - is - Show XY, Advanced Options - Type : dynamic, Allow last track to exceed time limit: yes, Sort Tracks: Newest.
When I click on Preview, the newest show is effectively displayed. This part works well.

This Smart Bolcs is then integrated into a playlist, which is selected in the calendar as an autoloading playlist.
The problem seems to be in the autoloading playlist area.
In reality, it does not search for the newest show. If there is already a playlist loaded from earlier, only this older playlist with old Smart Bloc is played. To be sure of this I will make more experiments. Maybe I made a mistake on an other part…