Analytics not loading


#1

I have my admin user and password entered correctly and I am still getting this error - Please make sure admin user/password is correct on Settings->Streams page.


#2

So this is actually asking for the Icecast admin password. Which you should change from the default of hackme under /etc/icecast/ see https://icecast.org/docs/icecast-2.4.1/config-file.html

If you do this you need to reload the icecast2 service - sudo service reload icecast2 and then it should start compiling the information under the statistics section. - see https://github.com/LibreTime/libretime/issues/333 for more information on what we need to do to fix this.


#3

Thank you @robbt

When I log into my server and type xmllint icecast.xml I get the following error -

warning: failed to load external entity “icecast.xml”

when I also go to access the xml file through /etc/icecast2/icecast.xml I get the following error:

-bash: /etc/icecast2/icecast.xml: Permission denied


#4

Apologies @robbt I used sudo and was able to edit.

However, I cannot reload icecast. I type, sudo service reload icecast 2 and get the error

reload: unrecognized service

As I cannot reload i get this in libre

Can not connect to the streaming server

401, Authentication Required (HTTP/1.0)


#5

For sure, you need to assume super user or root to edit /etc/icecast/icecast2.xml - usually if you are using a ubuntu distro this is accomplished through appending sudo in front of the command you are doing or else you can assume root with sudo su keep in mind this is basically overriding any of the permissions that might prevent you from damaging your system so it should be used sparingly. But in this case in order to edit the icecast.xml you will need root permissions.

If you aren’t familiar with the command line the easiest editor is probably nano so you would type
sudo nano /etc/icecast2/icecast.xml and then change the permissions.


#6

Thank you, I managed to get that done I am just having issues reloading icecast2 now


#7

ok, so basically here are few commands to try sudo /etc/init.d/icecast reload for older distributions
you might try sudo service icecast2 restart
or sudo /etc/init.d/icecast2 reload
If these don’t work - share your distribution and version.


#8

The last option worked, however, my libre stream settings now has this error and no audio -

Can not connect to the streaming server

could not write data to host: Connection refused in write()


#9

Ok you will need to know implement a custom setting under stream settings as it is hardcoded with the insecure default. basically just put in the admin login etc that you modified in icecast2.conf


#10

@robbt it is all the same information, can I send over a screenshot as a DM?


#11

The information will be the same (such as host) etc. but you will need to expand Additional Options and put in the passwords that you added. This should fix everything.


#12

@robbt ive sent the DM