Alsa Soundcard out not working


New to Libretime but love the idea of the project and potential.

I’ve managed to install Libretime on a Raspberry PI 3 running Raspbian Stretch. It was a bit of a battle (partly my own fault) but I got there in the end. I’ve made some notes along the way which I will share in due course for others wishing to use Libretime on a Raspberry Pi.

I’ve run into an issue which I’m not sure is a bug or a problem with my install. I have installed a USB soundcard onto the Pi. I believe it’s set correctly as default alsa soundcard output as when I play something from commandline (aplay “filename.wav”) I hear the audio correctly out of the soundcard.

When I enable Alsa output on Libretime not only is there no audio output, it also breaks the streaming output. The web interface shows songs playing as normal.

Any advice gratefully received, my linux level could be described as “basic” but I’m learning lots!




Just to update, I have managed to get this working so I thought I’d share my solution if anyone else comes across this issue.

It was down to permissions! Libretime runs liquidsoap under the apache user www-data. Just needed to add this user to the AUDIO group with the following command:

sudo usermod -a -G audio www-data

Sound and stream now working happily together.