Python version issues

Running Debian 10, have Python 2.7.16 and Python 3.7.3.

LT’s install script doesn’t have any calls for Python3, all calls are for Python, which is Python2.

The script attempts to install Python’s “importlib_metadata”, and finds and downloads the latest version, 4.6.4, which only works for Python3, which the script hasn’t found. The latest version that works for Python2 is 2.1.1, but then there’s clashes with Kombu 5.1.0, and amqp 2.6.1, which seems to be the highest version of amqp that installs.

Now I don’t know the details, but I understand there are enough differences between Python 2 and 3 that at times either one is required. However, after all of the above only calling on Python 2, the script stops with the following process and error:

Searching for importlib-metadata>=0.18
Reading Links for importlib-metadata
Best match: importlib-metadata 4.6.4
Processing importlib_metadata-4.6.4.tar.gz
Writing /tmp/easy_install-d6w7y7/importlib_metadata-4.6.4/setup.cfg
Running importlib_metadata-4.6.4/ -q bdist_egg --dist-dir /tmp/easy_install-d6w7y7/importlib_metadata-4.6.4/egg-dist-tmp-KpKYDd
error: find_namespace: directive is unsupported on Python < 3.3

Some slight versioning confusion?

LibreTime / Airtime looks like a nice setup for internet radio automation, but if it’s going to be a headache to set up, I’ll find something else. However, if I can help find these bugs and get them resolved for a better setup, I’ll do what I can.