Install libretime on stretch 9.1

From @kostkrom on Wed Oct 04 2017 09:12:21 GMT+0000 (UTC)

Installing libretime on stretch 9.1 is not supported. Any update on this?

Copied from original issue:

From @xabispacebiker on Wed Oct 04 2017 09:57:32 GMT+0000 (UTC)

I successfully installed Libretime in Debian Stretch, just needed to change a few files and it installed without any issues, although I needed to add a few missing packages.

I will create a new branch with the modifications asap.

From @hairmare on Wed Oct 04 2017 16:23:08 GMT+0000 (UTC)

I’ll be happy to merge them, I got sidetracked with running vagrant on libvirt when I tried to test the install on Stretch. There really isn’t any reason for running LibreTime on anything older than Stretch except that the installer needs to learn about Stretch and the docs need updating. See #303 for more info on this.

From @xabispacebiker on Thu Oct 05 2017 10:13:15 GMT+0000 (UTC)

Added Debian Stretch support

From @kostkrom on Sun Oct 08 2017 09:12:04 GMT+0000 (UTC)

I pulled the new changes but is not working on Raspbian 9.

From @hairmare on Sun Oct 08 2017 12:30:09 GMT+0000 (UTC)


This might be a Raspbian specific issue, can you post the output of the installer script to help us figure out what is failing?

From @kostkrom on Sun Oct 08 2017 14:31:36 GMT+0000 (UTC)

From @hairmare on Sun Oct 08 2017 14:35:02 GMT+0000 (UTC)

You need to use the git installer for now, sorry about not mentioning that earlier. I’ll to a tarball release that contains the fixes very soon.

From @hairmare on Sun Oct 08 2017 14:36:32 GMT+0000 (UTC)

Oh also, you might need to hack the installer script to support Rasbian, previous Raspberry Pi users seem to have used Debian on the device.

From @amavarick on Sat Oct 14 2017 21:19:43 GMT+0000 (UTC)

Virgin Debian 9.1 Stretch install failing… Airtime playout service fails to start

airtime-playout.service: Failed to set invocation ID on control group /system.slice/airtime-playout.service, ignoring: Operation not permitted

 Started Airtime Playout Service.
: 2017-10-14 16:15:17,641 [__main__] [INFO ]  New locale set to: C
: Traceback (most recent call last):
:   File "/usr/bin/airtime-playout", line 4, in <module>
:     __import__('pkg_resources').run_script('airtime-playout==1.0', 'airtime-playout')
:   File "/usr/local/lib/python2.7/dist-packages/pkg_resources/", line 748, in run_script
:     self.require(requires)[0].run_script(script_name, ns)
:   File "/usr/local/lib/python2.7/dist-packages/pkg_resources/", line 1517, in run_script
:     exec(code, namespace, namespace)
:   File "/usr/local/lib/python2.7/dist-packages/airtime_playout-1.0-py2.7.egg/EGG-INFO/scripts/airtime-playout", line 4, in <module>
:     runpy.run_module("pypo", run_name="__main__")
:   File "/usr/lib/python2.7/", line 192, in run_module
:     fname, loader, pkg_name)
:   File "/usr/lib/python2.7/", line 72, in _run_code
:     exec code in run_globals
:   File "/usr/local/lib/python2.7/dist-packages/airtime_playout-1.0-py2.7.egg/pypo/", line 154, in <module>
:     configure_locale()
:   File "/usr/local/lib/python2.7/dist-packages/airtime_playout-1.0-py2.7.egg/pypo/", line 144, in configure_locale
:     current_locale_encoding = locale.getlocale()[1].lower()
: AttributeError: 'NoneType' object has no attribute 'lower'
: airtime-playout.service: Main process exited, code=exited, status=1/FAILURE
: airtime-playout.service: Unit entered failed state.
: airtime-playout.service: Failed with result 'exit-code'.
: airtime-playout.service: Service hold-off time over, scheduling restart.
: Stopped Airtime Playout Service.
: airtime-playout.service: Start request repeated too quickly.
: Failed to start Airtime Playout Service.
: airtime-playout.service: Unit entered failed state.
: airtime-playout.service: Failed with result 'exit-code'.
sudo apt -y install git && sudo git clone
cd /root/libretime
./install -iap


root@stream3:/etc/init.d# initctl list | grep airtime-playout
-bash: initctl: command not found
root@stream3:/etc/init.d# apt install upstart
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package upstart is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  sysvinit-core systemd-sysv

From @hairmare on Sun Oct 15 2017 11:55:58 GMT+0000 (UTC)

You seem to be on a minimal install without locale.

localectl set-locale LANG="en_US.utf8"

Also, no need for upstart, the installer configures systemd, you can use something like this:

# check status
systemctl status airtime-playout

# look at logs:
journalctl -u airtime-playout

# follow logs:
journalctl -u airtime-playout -fn

The bug from #334 might also be affecting you if you are on master.

From @amavarick on Tue Oct 17 2017 01:09:30 GMT+0000 (UTC)

You’re correct about the minimal install without locale… Using a new VPS for development purposes that apparently didn’t set the locale. My prod VPS service allows me to install from iso so I don’t run into this issue.

Using your command wasn’t enough as postgresql coughed on the locale… For some reason dpkg-reconfigure locales didn’t work for me either. The following commands worked for me to get every entry populated with correct locale. Anyone else using this who is not en_US may want to use their own for this command…

#Purge all locales but en_US.UTF-8
sudo locale-gen --purge en_US.UTF-8
#Populate LANGUAGE=
sudo update-locale LANGUAGE="en_US.UTF-8"

reboot to apply…
Worked like a charm, installing libretime was without problem and all services started properly.