"Wrong username or password provided. Please try again."

I have a new install, but cannot log in. I’m using the default “airtime” user and “airtime” password, but it won’t let me in. Any suggestions would be appreciated.

Was this on a completely new machine or was there perhaps an existing database from a previous install ?

Also can you see if there are any errors in zendphp.log in /var/log/airtime

Thanks for the response.

This is a completely new installation on a freshly built os. Thanks also for the suggestion to look at the log. (My apologies for not thinking of that myself.) Anyway, here is the zendphp.log:

2020-06-21T07:22:30-05:00 INFO (6): ubuntu42 Registered Component: pypo@127.0.0.1
2020-06-21T07:22:39-05:00 INFO (6): ubuntu42 Registered Component: show-recorder@127.0.0.1
2020-06-21T07:22:39-05:00 INFO (6): ubuntu42 Notifying RabbitMQ to send message to pypo
2020-06-21T07:23:30-05:00 INFO (6): ubuntu42 You must explicitly start the session with Zend_Session::start() when session options are set to strict.

So next question, what distribution and release of Linux are you running this on and which php version is it using ? Also are you running the latest got master version of libretime, and if not can you try an installation with that and see if it works ? The session issue makes me think you are running into a issue with php compatibility that we might have fixed with the latest code or actually it should be fixed upstream by zf1s. So let me know this info and I’ll see if I have any more troubleshooting suggestions.

I appreciate the help. First I installed 18.04 LTS and updated it. Then I installed Libretime following instructions at: https://libretime.org/quickstart.html.

Here is from .bash_history:

sudo apt install ssh
sudo apt install git
git clone https://github.com/LibreTime/libretime.git
cd libretime
sudo ./install -fiap
sudo adduser www-data audio
sudo ufw enable
sudo ufw allow 80/tcp
sudo ufw allow 8000/tcp
sudo ufw enable 8001/tcp
sudo ufw allow 8001/tcp
sudo ufw allow 8002/tcp
sudo systemctl start libretime-playout
sudo systemctl start libretime-liquidsoap
sudo systemctl start libretime-analyzer
sudo systemctl start libretime-celery

I assume that will pick up the latest release. :slight_smile: (I’ve been wrong before.) Total newby here with Libretime, (but am very familiar with Airtime). PHP that installed is 7.2.

I did not follow the instructions for setting up a static address in netcfg.yaml and set one up via interfaces, and my lan router agrees. But possibly it is a factor in the problem, as I didn’t exactly follow instructions. (Also, there are two errors on that quickstart page related to ufw, both
sudo ufw enable 8001/tcp and sudo ufw enable 8002/tcp return error, and “enable” should be “allow”, I think. I looked at /etc/airtime/airtime.conf and [ladp] still has hackme password. I don’t know enough to know whether that could be related. In the login form is a link for previous user/password pairs and airtime/airtime is there. I do know whether the login uses postgresql database. Or if some file permissions might be wrong. My firewall reads like this:
To Action From
– ------ ----
[ 1] 80/tcp ALLOW IN Anywhere
[ 2] 8000/tcp ALLOW IN Anywhere
[ 3] 8001/tcp ALLOW IN Anywhere
[ 4] 8002/tcp ALLOW IN Anywhere
[ 5] 22/tcp ALLOW IN Anywhere
[ 6] Anywhere ALLOW IN 172.16.0.0/16 22/tcp
[ 7] 80/tcp (v6) ALLOW IN Anywhere (v6)
[ 8] 8000/tcp (v6) ALLOW IN Anywhere (v6)
[ 9] 8001/tcp (v6) ALLOW IN Anywhere (v6)
[10] 8002/tcp (v6) ALLOW IN Anywhere (v6)

I was able to get in by resetting the password for user admin, via instructions on this page:
https://forum.sourcefabric.org/discussion/12532/forgot-airtime-password/p1