# Installing on Synology NAS via Docker

**URL:** https://discourse.libretime.org/t/installing-on-synology-nas-via-docker/1267
**Category:** Uncategorized
**Created:** [July 12, 2022, 8:38am UTC](https://discourse.libretime.org/t/installing-on-synology-nas-via-docker/1267 "2022-07-12T08:38:09Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![simistef](https://yyz2.discourse-cdn.com/flex036/user_avatar/discourse.libretime.org/simistef/32/624_2.png) [@simistef](https://discourse.libretime.org/u/simistef)
#### Post date: [July 12, 2022, 8:38am UTC](https://discourse.libretime.org/t/installing-on-synology-nas-via-docker/1267/1 "2022-07-12T08:38:09Z")

</div>

Hi all,

I tried to install Libretime on a Synology NAS DS218+ via Docker using this container: [Docker Hub](https://hub.docker.com/r/odclive/libretime-docker)

Managed to run most of it until the final step where services need to be started. The message i get is:

```auto
admin@Diskstation:~$ sudo systemctl start libretime-playout
Failed to start libretime-playout.service: Unit libretime-playout.service failed to load: No such file or directory.

```

Anyone able to help a bit on how can i fix this ? Thanks in advance!

---

<div class="post-metadata">

### Author: ![simistef](https://yyz2.discourse-cdn.com/flex036/user_avatar/discourse.libretime.org/simistef/32/624_2.png) [@simistef](https://discourse.libretime.org/u/simistef)
#### Post date: [July 12, 2022, 9:51am UTC](https://discourse.libretime.org/t/installing-on-synology-nas-via-docker/1267/2 "2022-07-12T09:51:40Z")

</div>

ok, managed to go over this by simply restarting the docker container.

but now the Liquidsoap service has not started.

i tried to run this and fails for me apparently:

```auto
admin@Diskstation:~$ sudo docker run -p 80:80 -p 8000:8000 -p 8001:8001 --name=libretime3 odclive/libretime-docker:latest
docker: Error response from daemon: driver failed programming external connectivity on endpoint libretime3 (f0769552c5de2d7e12ac4f58e5ccb919304f373a77f1d6cc6ee922a561d4ad99): Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use.
ERRO[0000] error waiting for container: context canceled 
admin@Diskstation:~$

```
